Retail Application - Deal Loading Slowness

Incident Report for Tekion

Resolved

All functionality has returned to normal and we are considering this incident resolved. If you continue to see issues please refresh your browser and if issues persist please reach out to the Tekion Support team.
Posted Feb 28, 2026 - 23:07 UTC

Monitoring

At this time Desking is returning to normal operation and all dealers should be able to proceed with deal desking. We will continue to monitor to ensure stability before considering this event Resolved.
Posted Feb 28, 2026 - 21:56 UTC

Identified

We have identified the issue and continue to work towards a solution with highest priority. We will continue to update as we get near a solution
Posted Feb 28, 2026 - 21:47 UTC

Investigating

We are currently aware of an issue with loading the Deals list and potentially loading deals. We are actively investigating and will provide an update as quickly as possible.
Posted Feb 28, 2026 - 20:28 UTC
This incident affected: ARC (Retail).