Tekion ARC Retail Application Issue - Tax and Fees

Incident Report for Tekion

Resolved

The Tekion ARC Retail Application Issue for Tax and Fees has been Resolved. If you are experiencing any additional related issues, please contact Tekion Support for further assistance. Thank you for your patience and understanding.
Posted Jul 30, 2025 - 14:57 UTC

Identified

Tekion is currently aware of an issue affecting tax and fee calculations for some dealers. Our Engineering team is actively working on a resolution. The estimated time to resolution is 60 minutes.

We appreciate your patience and will provide further updates as soon as they are available.
Posted Jul 30, 2025 - 14:32 UTC
This incident affected: ARC (Accounting, Parts, Retail, Service, Core, Analytics, CRM, Payroll, Integrations).