Awareness: Issues with F&I Menu product rating and PDF generation

Incident Report for Tekion

Resolved

The Third Party Vendor issues that was impacting their available services with Tekion has been Resolved. Tekion ARC Applications remain fully Operational. If you experience any related issues please contact Tekion Support. Thank you again for your patience and understanding.
Posted Oct 20, 2025 - 21:49 UTC

Monitoring

The impact affecting Tekion due to third-party vendor service interruptions has been mitigated with several of our vendors. Tekion ARC Application Printing Services and many F&I Menu Services are now operational.

However, some issues with other third-party vendors may persist and are being monitored. Chat support has also been restored. If you experience any related problems, please contact Tekion Support. Thank you for your patience and understanding.
Posted Oct 20, 2025 - 20:54 UTC

Identified

Valued Dealer Partner, Tekion is aware of a Third Party Vendor issue that is causing issues with Retail F&I Menu product rating and PDF generation and are working on them with our partners.

Please use Email or the ARC Portal to contact Tekion Support with issues as Live chat is also impacted. We will continue to provide updates as information becomes available.
Posted Oct 20, 2025 - 19:39 UTC

Monitoring

Valued Dealer Partner, Tekion is aware of a Third Party Vendor issue that is causing issues with Retail F&I Menu product rating and PDF generation and are working on them with our partners. We will continue to provide updates as information becomes available.
Posted Oct 20, 2025 - 19:25 UTC
This incident affected: ARC (Accounting, Parts, Retail, Service, Core, Analytics, CRM, Payroll, Integrations).