The Tekion Engineering team has resolved the issue concerning CRM. Please reach out to the Tekion Support team if any additional assistance is needed.
Posted Sep 26, 2025 - 12:01 UTC
Update
The Tekion Engineering team continues to work on a resolution impacting CRM. We greatly appreciate your patience. We will provide an update within the next hour.
Posted Sep 26, 2025 - 11:20 UTC
Identified
Tekion has Identified an issue impacting access to the Tekion ARC- CRM application. Our Engineering team is actively working to address the issue and resolve. We appreciate your patience and understanding. We will provide an update within the next hour.