Tekion ARC Retail F&I Application Issue

Incident Report for Tekion

Resolved

The Tekion Retail PEN Application slowness Issue impacting the Deal F&I screen and F&I Products ratings has been Resolved as noted by PEN. If you are experiencing any additional related issues, please contact Tekion Support for further assistance. Thank you again for your patience and understanding. Tekion will monitor for any additional alerts from PEN Solutions.
Posted Sep 17, 2025 - 16:54 UTC

Monitoring

Tekion Engineering is currently monitoring performance issues with PEN Applications. PEN team is actively working to resolve this issue and will provide updates. This issue will impact the Retail Deal F&I screen and F&I Products rating. We appreciate your patience and understanding. We will provide an update to you as more information becomes available.
Posted Sep 17, 2025 - 16:34 UTC

Investigating

Tekion is Investigating a slowness issue within the ARC Retail F&I application. Our engineering team is actively engaged and working diligently to identify and resolve the issue as quickly as possible. We appreciate your patience and understanding. We will provide an update to you as more information becomes available.
Posted Sep 17, 2025 - 16:24 UTC
This incident affected: ARC (Retail).