Azure Service Outage Impacting 3rd-Party Integrations

Incident Report for Tekion

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 23:18 UTC

Update

The recent Microsoft Azure service disruption has been resolved. Tekion’s core platform, hosted on AWS, remained fully operational throughout the event, and your critical business functions continued without interruption.

As with most technology providers, some Tekion integrations rely on third-party partners who may themselves use cloud services like Azure. In these cases, a few integrations—such as RouteOne—may have experienced intermittent connectivity or delays. These services have now been restored and are operating normally.

Tekion’s cloud-native architecture is designed for resilience and business continuity, with multiple safeguards and fallback workflows in place to minimize exposure to third-party outages.

If you have any questions or continue to experience anomalies, please reach out to our Support team.
Posted Oct 29, 2025 - 23:18 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 29, 2025 - 23:14 UTC

Monitoring

We are aware of an active service outage reported by Microsoft Azure. While Tekion ARC is hosted on AWS and remains fully operational, some of our integrated 3rd-party partners—such as RouteOne—may currently experience degraded performance or intermittent connectivity as a result of the Azure disruption.
We are actively monitoring the situation and will provide updates as more information becomes available.
Thank you for your patience and understanding.
Posted Oct 29, 2025 - 16:55 UTC
This incident affected: ARC (Accounting, Parts, Retail, Service, Core, Analytics, CRM, Payroll, Integrations).