Tekion CRM is experiencing delays with lead activity, communications and appointment

Incident Report for Tekion

Resolved

The Tekion CRM Lead activity delays Issue has been Resolved. If you are experiencing any additional related issues, please contact Tekion Support for further assistance. Thank you for your patience and understanding.
Posted Mar 04, 2026 - 17:10 UTC

Identified

We are currently experiencing delays with lead activities. Engineering has identified the issue and is taking steps to resolve right now. We appreciate your patience and understanding. We will provide an update within the next hour.
Posted Mar 04, 2026 - 15:56 UTC
This incident affected: ARC (CRM).