CRM - Delays with Lead Assignment Triggers

Incident Report for Tekion

Resolved

The CRM Lead Assignment Issue has been resolved. Leads are assigning immediately and triggering process automation at this time. If you are experiencing any additional related issues, please contact Tekion Support for further assistance. Thank you for your patience and understanding.
Posted Feb 26, 2026 - 18:57 UTC

Identified

Tekion has Identified the issue impacting the CRM Lead Assignment rules not triggering. Our engineering team is working diligently to resolve the issue as quickly as possible. We appreciate your patience and understanding. We will provide an update within the next hour.
Posted Feb 26, 2026 - 18:17 UTC

Investigating

We are currently experiencing delays with Lead Assignment rules triggering. Once the rules trigger, the associated process automations will run as expected. Our Engineering team is actively investigating the root cause and working to resolve the issue as quickly as possible.

As a temporary workaround, users can manually assign the lead to trigger the associated process automation immediately
Posted Feb 26, 2026 - 17:36 UTC
This incident affected: ARC (CRM).