Tekion ARC System - Parts and Service

Incident Report for Tekion

Resolved

The Tekion Engineering team has resolved the issue concerning Parts & Service. Please reach out to the Tekion Support team if any additional assistance is needed.
Posted Sep 26, 2025 - 12:03 UTC

Identified

Tekion has Identified an issue impacting the Tekion ARC application for Parts and Service. Our Engineering team is actively working to address the issue and resolve. We appreciate your patience and understanding. We will provide an update within the next hour.
Posted Sep 26, 2025 - 10:47 UTC
This incident affected: ARC (Parts, Service).