Tekion ARC Application Issue - Concierge and iPad Casting Unavailable

Incident Report for Tekion

Resolved

The Tekion ARC Retail Concierge and iPad Casting applications issue has been Resolved and is Operational. If you are experiencing any additional related issues, please contact Tekion Support for further assistance. Thank you for your patience and understanding.
Posted Oct 24, 2025 - 15:24 UTC

Identified

Tekion has Identified the issue impacting the ARC Retail Concierge and iPad Casting applications. Our engineering team is working diligently to resolve the issue as quickly as possible. We appreciate your patience and understanding. We will provide an update within the next 2 hours.
Posted Oct 24, 2025 - 14:36 UTC
This incident affected: ARC (Retail).