Awareness: Upcoming Maintenance Notice

Incident Report for Tekion

Resolved

This incident has been resolved.
Posted Oct 07, 2025 - 16:51 UTC

Update

Upcoming Maintenance Notice
To keep your experience fast, reliable, and secure, we’ll be performing overnight improvements to our cloud systems.

When: Oct 6, 2025, 9:30 PM PST – Oct 7, 2025, 2:30 AM PST

What to Expect:
• Brief interruptions may occur a few times during this window
• Some features may show errors for a few minutes at a time

No action is required at this time by our Dealer Partners. If you have any questions, our Tekion Support team is here to help.
Posted Oct 06, 2025 - 13:06 UTC

Monitoring

Upcoming Maintenance Notice
To keep your experience fast, reliable, and secure, we’ll be performing overnight improvements to our cloud systems.

When: Oct 5, 2025, 9:30 PM – Oct 6, 2025, 2:30 AM PST

What to Expect:
• Brief interruptions may occur a few times during this window
• Some features may show errors for a few minutes at a time

No action is required at this time by our Dealer Partners. If you have any questions, our Tekion Support team is here to help.
Posted Oct 03, 2025 - 14:14 UTC
This incident affected: ARC (Accounting, Parts, Retail, Service, Core, Analytics, CRM, Payroll, Integrations).